ChemFinder 7.0.3 Features

[ CS Intranet | ChemFinder Home | 7.0.3 Fix List ]


updated 4 May 02

The following are the new features of ChemFinder 7.0.3 which ought to be mentioned in the user documentation.

Subform linking Version info Upgrade dialog suppress Read-only forms
Print selection CFW file extensions SQL debugging Text searching
Reaction parsing Font changes (new) Dominick's list (new) Subforms in table (new)
Auto labels (new)

Subform linking

In ChemFinder 7.0.3, the Subform Properties dialog has been changed to reduce user confusion.  This dialog is presented when you right-click the header of a subform box and choose Properties.  Its purpose is to allow you to specify which columns link the main table with the selected subtable.

In this new version:

For related info, see Setting Subform Links in ChemFinder 7.0.3


Version info

The data displayed in About Box, Splash Screen, and File Properties are different for 7.0.3, not just for ChemFinder but also MolServer, CF Word, and other components.  For complete details, see Fixes in ChemFinder 7.0.3 Version Scheme.


Upgrade dialog suppress

In ChemFinder 7.0.3, you can suppress the alert asking if you wish to upgrade a database to the latest version.  You do this on a form-by-form basis, using a new checkbox on the Form Properties dialog:

For a form attached to an old-format database, check Do not ask to upgrade if you do not wish to be prompted about upgrading every time you open the form.

You must save the form after checking this box.  The feature takes effect the next time you open the form.


Read-only forms

Another new checkbox on the Form Properties dialog (see picture above) is Open database read-only.  Check this box, then save the form, and subsequently when you open the form it will open its database in read-only mode.


Print changes

Prior to 7.0.3, when you chose File Print, the default action was to print the entire current list, which often meant the entire database.  In 7.0.3 there is a new option and a new default.  When you choose File Print, the Print dialog shows a new Selection radio button under Print range:

Print Selection means: print one page starting from the current record, taking into account the number of records per page as established in Page Setup.  This works in either form or table view.  It is the default option, chosen automatically every time you bring up the Print dialog.

Note: the default is All, not Selection, when printing from Table View.

Also changed in 7.0.3: if a subform is active when you choose Print or Print Preview, the program no longer prints just the contents of the subform.  The entire form is printed, regardless of what is active when the command is chosen.


CFW file extensions

ChemFinder 7.0.3 can open a formfile with any file extension; it need not be .cfw.  This is true when opening via File Open, via drag-and-drop from Windows Explorer; or when running the program from the command line.  However:

Exception:  the extension .cfview is being used with recent eCatalog forms, specifically to run ChemFinder 7.0.2 Net.  Details from Brian:

Finder Net 7.0.2, which shipped with the E-Catalogs, behaves as follows:

In the presence of another ChemFinder, determined by the presence of a cfw.exe file on the system at install time, the Net 7.0.2 executable is installed but NO registry entries are made for the program EXCEPT the new file type.

If NO OTHER FINDER is present, determined by the absence of a cfw.exe file on the system at install time, the Net 7.0.2 executable is installed and ALL registry entries are made for the program including the new file type.

The registry entries which are conditionally installed include entries such as the .cfw extension, OLE automation keys, etc.

The new file type is determined during development and the installer merely associates that file type to the installed CF Net 7.0.2 executable. Thanks to the changes made in 7.0.2, CF Net will successfully open a file of any extension on double click, provided that extension is associated with the 7.0.2 exe.

In the case of the Lancaster and TCI E-Catalogs, the new file extension used was .cfview


SQL debugging

ChemFinder 7.0.3 offers a new feature for diagnosing database problems.  You can choose to collect in a file all the SQL strings generated by ChemFinder.  These can then be submitted to Access or SQL*Plus for testing or verification.

To output SQL to file:

Under HKCU\Software\CambridgeSoft\ChemFinder\7.0\Pro\Debug, set the key DBG_SQL to 1.  (If you don't see this key in the Registry, start ChemFinder, exit, then look again.)

When the DBG_SQL key is on (set to 1), all generated SQL statements are written to the file c:\cf_sql.txt.  New statements are appended to the file, so it will continue to grow as long as the DBG_SQL switch is on.  Set the key back to zero when you are finished, or periodically erase the file contents, so the file doesn't balloon out of control.

Each execution of a statement opens the file, appends the statement, and closes the file.  This means you can inspect c:\cf_sql.txt after each search and see the new statements just executed.


Text searching

Here is the official documentation from ChemFinder 7 Help, with 7.0.3 modifications in color:

Text Search Examples

Given the following records in a database:

  1. abc
  2. abcx
  3. xabc
  4. xabcx
  5. abc x
  6. x abc
  7. x abc x

Here is the table of hits:

query type full-word hits does not hit comments
abc text off 1,2,5 3,4,6,7 anchored match
  text on 1,5 2,3,4,6,7 anchored match
  memo off 1-7   floating match
  memo on 1,5,6,7 2,3,4 floating match
abc* text off 1,2,5 3,4,6,7  
  memo off     no hits*
  text on 1,5 2,3,4,6,7  
  memo on     no hits*
*abc text off 1,3,6 2,4,5,7  
  memo off     no hits*
  text on 1,6 2,3,4,5,7  
  memo on     no hits*
*abc* text off 1-7    
  memo off 1-7    
  text on 1,5,6,7 2,3,4  
  memo on 1,5,6,7 2,3,4  
= abc text any 1 2-7  
= abc memo any     no hits*

*These memo searches found no hits because text is stored in rich-text format.  For example, "abc" is stored as:

{\rtf1\ansi\ansicpg1252\deff0\deflang1033{\fonttbl{\f0\fnil\fprq2\fcharset0 MS Sans Serif;}}
\viewkind4\uc1\pard\f0\fs15 abc
\par }

You can see this rich-text data by exporting records to SDFile and examining it in Notepad.

For more info on this subject, see Text Search project notes.


Reaction parsing

When you draw a reaction, you typically draw two or more molecules, at least one arrow, maybe some plus signs, and you expect the program to figure out which molecules are reactants and which are products.  ChemDraw and ChemFinder have different mechanisms for doing this, and the two methods can give different results.  For example:

The correct interpretation of this reaction has three reactants and one product.  Until recently ChemDraw thought it had two of each, and so did ChemFinder, and they both got it wrong in different ways. This has been a problem for E-Notebook, which uses the ChemFinder interpretation (via MolServer).

For an excellent description of how the ChemFinder algorithm works, and a plan for a much better one, see Harold's white paper on reaction layout.

In ChemOffice 7.0.3, both programs still have their own mechanisms for doing the interpretation (we hope to correct this in 8.0) but both have been improved.  ChemDraw 7.0.3 now considers any molecule under the arrow to be a reactant (see CSBR-23355).  Here is how ChemDraw interprets reactions (thanks Jonathan!):

Draw a line perpendicular to the arrow passing through the tip of the arrowhead. Every fragment whose center is on one side of the line is a reactant; every fragment whose center is on the other side is a product. This works appropriately for non-horizontal arrows, too.

ChemFinder 7.0.3 now uses ChemDraw's interpretation for one-step reactions (see CSBR-28686).  If you draw a reaction with exactly one arrow, then ChemFinder takes the reactant and product info from the CDX delivered to it.  In other cases (multiple arrows, inability to interpret), ChemFinder uses its own interpretation scheme as usual.

Note sneaky trick: if you are a tester, or just curious, you can compare how the two programs interpret the same reaction.  Draw it with a single arrow and bring it into ChemFinder.  If you are using ChemFinder-style display, you will see how ChemDraw interpreted the reaction -- it becomes a linear sequence, A + B + C -> D.  If you want to see how ChemFinder would have interpreted it, go back and add a second arrow.

Note: If you are using ChemDraw-style display, you will see the reaction exactly as you drew it.  The same is true if you double-click to edit in ChemDraw --- the original is what you edit, regardless of your display choice in ChemFinder.


Font changes

Due to an impassioned plea from Wyeth, we've finally corrected a clumsy aspect of the ChemFinder UI: setting fonts on form boxes.  Previously, the Text menu and Text Format toolbar were available only when editing a memo field in a rich text box.  To set the font for a regular data box, you had to bring up Box Properties and click the Font button, and this had to be done individually for every box.  

In 7.0.3, the Text menu and toolbar are now available:

Text format applied to selected boxes

In all these situations, the toolbar shows the current font(s) of the selection, and any changes you make apply to the entire selection.  All changes are multi-level undoable.

Testing Tutorial

The way this feature works should be fairly obvious, but here's a tutorial / test checklist:

  1. Open a form with some text boxes.  For testing, include a rich text box.  (Easy way to get a database with a memo/richtext field: import an sdfile, double-click a field in the pre-import dialog and set its type to memo, then import.)
     

  2. View > Toolbars > Text Format to bring up the toolbar.  It should be disabled until you do the next step.
     

  3. Select something: click a text box, select multiple boxes, or otherwise get yourself into one of the three situations described above.  The toolbar should update to reflect the font and style of the current selection, with items blanked for mixed multi-selects.  Toolbar is dimmed if no selection is available.
     

  4. Change something: choose font name, size, or style.  Note that some styles are not available unless you are editing rich text, as reflected in dimmed toolbar buttons (rich text only: paragraph styles, super/subscripts, bullets).  The style you change will be applied to the entire selection, except: a style applied to a framed box affects the data box only, not the frame(*).
     

  5. Edit > Undo Font Change.  Undo and Redo should work as expected.
     

  6. To be tested: what shows in the Text Format toolbar should match what you see in Box Properties for any individual box.  You can change the font in either place and it is reflected in the other.
     

  7. To be tested: the Text Format toolbar and the Text menu should work the same in all ways, including dimming of unavailable items.
     

  8. Note: changing the box font of a rich-text box doesn't always work as expected.  There is a default font associated with the box, but the text inside may have a different font applied to it.  There are some glitches in the way this works; they've been there a long time, and we didn't fix much.
     

  9. To be tested: apply format changes to all types of boxes, including structure, formula, picture, plain text, subforms.
     

  10. Bug: changing the text color of a rich text box does not seem to work.

(*) To change the font of a frame, select just it.  It might first be necessary to "separate" it from its data box: click the databox and choose Edit > Bring To Front, then you can select or move the box and frame independently.


Subforms in Table View

The number one request from Dominick included a tirade about the non-intuitivity of displaying subform data in table view.  Until now, this feature was controlled by a general preference called "Export subform data."  Raise your hand if you already knew that.

In 7.0.3, we have added a checkbox to the Subform Properties tab, "Show in table view."  (To do this, we had to shorten some other items.  They're still clear, aren't they?)  This checkbox determines whether a subform is to be displayed in a column of Table View, as illustrated here:

Each subform can be marked independently, the settings are saved in the formfile, and it all makes a lot more sense now.


Automatic Frame Labelling

Another request from Dominick called "the most glaring omission," was to have the frame around a data box display the field name of that box.  This is fixed in 7.0.3 as follows:  when you right-click on a databox and choose a fieldname from the drop-down list, then if the box has a frame, the frame label is automatically changed to display the fieldname.

To create a new framed box showing a given data type:

  1. Activate the Framed Box tool.

  2. Draw a framed box on the form.

  3. When prompted to add "label" to the frame, just click OK or press Enter.

  4. Right-click in the center of the data box, and select a field from the drop-down list.  (This assumes you have already opened a database.)

  5. The label changes from "label" to the chosen fieldname.  (To change it to something else, right-click on it and choose Label or Properties.)

Note: changing the field in any other way, such as in Box Properties, does not automatically update the label.  This works only when you choose a fieldname from the drop-down list.


Copyright 2002 CambridgeSoft Corp. All Rights Reserved.
Proprietary and confidential to CambridgeSoft Corp.
Last updated: 06/15/2002
Pagekeeper:  Jim