UI Features

 

Updated 2/12/01 (Open Last Form on Startup)

Updated 2/16/01 (Search Options dialog)

Updated 4/26/01 (Stereochemical Search Preferences dialog)

 


Drop-Down Choice Lists
Subforms in Table View
ChemDraw Display
Folders in Data Source Tree
Automatic Form Generation
Improved Box Properties
Align/Distribute
Opening Dialog
Open Last Form on Startup
Changes in Picture Boxes
Revamped Search Options Dialog


Drop-Down Choice Lists

One popular request among users is the ability to save typing and avoid mistakes by choosing input data from a list, for data types which have a limited list of choices.  This has been implemented as a new property you can apply to a form box.

 

To set up a list of choices on a form box, check the new With drop-down choices box in Box Properties:

 

 

Checking this box generates a new tab in the dialog and brings it to the front:

 

 

You have two options for generating a list of data choices:  entering the list by hand (as shown above), or retrieving the list from a table in the current database.

 

To enter a list by hand, choose Fixed list of choices and type the data items into the list box.  To insert a carriage return between lines, use Ctrl-Enter.

 

To retrieve the list from a table, choose From table, then choose the table and column from the data source tree.  Data items will be displayed as soon as you select a column.  If you choose a table with more than 30 items in it, the list will be truncated.  (The limit of 30 is adjustable; edit the MAX_CHOICES line of CFW.INI.)  If you use the From table option, the drop-down list will always reflect the current contents of the named table, not just the items shown at setup time.

 

You can use a combination of these approaches.  Choose From table, retrieve a column of data, then choose Fixed list.  The contents of the column then becomes a fixed list which may be edited (but will not change if the table changes).

 

Once you have set up a choice list for a form box, it is easy to use.  Whenever you click in the box, a little button appears in the lower right corner.  Clicking this button brings up the choices.  Choosing one will deposit it into the form box, just as if you had typed it.

 


Subforms in Table View

Dedicated ChemFinder users who enjoy table view and subforms have until now not been able to use them together.  ChemFinder/RS3 corrects this deficiency.  Subform columns are now displayed in the table view window of the main form, along with the columns of the main table.  For example, table view of Cs_demo now looks like this:

 

 

Each box of the subform corresponds to a column in the view, where, as indicated, if the subform contains multiple records, then the table view cell contains multiple lines.  Headers of the subform columns are distinguished by having the corresponding table names appended in brackets.

 

If you don’t wish to have all boxes of the subform visible in this view, you may do the following.  With the main form in form view, click in a subform to activate it, then display the subform in table view (double-click in the subform).  For the columns you do not wish to display, “squeeze them shut”: hide them by reducing to zero width.  None of these hidden columns will appear in the main table view.

 


ChemDraw Display

A significant feature of ChemFinder/RS3 is the ability to display structures using ChemDraw rendering.  For any structure box, you may choose the form of display:

 

 

ChemDraw style diagrams include all the nice features of ChemDraw, such as gaps in crossing bonds and scaled text.  However, they do not include element coloring, as ChemFinder style does.


Folders in Data Source Tree

As mentioned in the description of the Wizard table screen, ChemFinder/RS3 makes it possible to organize tables of a data source tree into folders.  This applies not only to the Wizard but wherever such trees appear, as in Box and Form Properties and Attach Table dialogs.  For example, here is an organization of the NorthWind database supplied with Microsoft Access:

 

 

To describe these folders, you must use a text editor to create a file called FOLDERS.TXT in your ChemFinder\System directory.  This file can contain folder schemes for as many databases as you wish.  For each database, create a section such as the one used in this example:

 

DB          Northwnd.mdb

FOLDER      Tables      T

FOLDER      Orders      T

ITEMS       Order*

ENDFOLDER

FOLDER      People

ITEM        Customers

ITEM        Suppliers

ITEM        Employees

ENDFOLDER

REST

ENDFOLDER

FOLDER      Views       V

ITEMS       *

ENDFOLDER

ENDDB

 

Each database section is delimited by DB/ENDDB statements, each folder by FOLDER/ENDFOLDER. Contents of a folder are specified by using table names, names with wildcards, or special keywords.  The complete vocabulary of this file is documented in the sample folders.txt file.

 


Automatic Form Generation

New 12/18/00 (ver 7.0d162): field chooser and other new features.  This section rewritten.

 

The form generation feature developed for the Database Wizard is also available directly in ChemFinder. You can use the form generator to create a new form or to restyle an existing one, whether it be a main form, subform, tabbed form, or miniform in continuous view.  You can choose which fields to include in the form, and select from various style parameters, then click once to create a neat, grid-aligned, fully functional form.

 

Note: Unlike the Wizard version, the form generator in ChemFinder does not allow automatic creation of subforms.  However, you may create a subform manually, then use the form generator to create its contents.

 

To create a form automatically in a blank window:

  1. Right-click on a blank form and choose Database...

  2. Open a database and select a table.

  3. Click the Form tab.  Check the new Generate new form checkbox:

 

  1. Click the Style... button.  This brings up the Form Generation dialog:

 

  1. Under Choose fields to be included, put a checkmark next to every field for which you want a box on the form.  By default, all fields are included.  (Currently, choices made here are not saved; the dialog always comes up with all boxes checked.  We hope to fix this.)

  2. Check Structure in upper left of form if you want the structure box to be the first one generated, at the top of the first column.  Otherwise boxes are generated in the order they appear in the field list.

  3. Choose a form style: Framed, Titled, Labelled, or Plain.

  4. Indicate the number of columns, between 1 and 4, and the size and spacing of boxes and grid (Small, Medium, or Large).  To understand what these settings do, experiment.  You can easily regenerate forms until you get one you like.

  5. Click OK to save and dismiss the form generation settings.

  6. Click OK again to dismiss the form properties dialog.  This generates the form.  The above settings generate the following form:

 

-- 3/26/01: this picture seems to have been overwritten --

 

Notes

If you Cancel this alert, no new form is generated, but you are no longer in Box Properties.

 


Improved Box Properties

As screen shots throughout this document show, the Box Properties / Form Properties dialog in ChemFinder/RS3 has been redesigned.  A new Table tab was added, along with list controls for displaying more data with less screen clutter

 

 


Align/Distribute

For easier form editing, ChemFinder 7 offers the familiar Align/Distribute functions under the Edit menu.  When two or more boxes are selected, you can align them by any edge or by center.  When three or more boxes are selected, you can distribute (space them evenly) horizontally or vertically.

 

 

To align boxes:

  1. Select two or more boxes.

  2. Choose an Align command from the Edit menu.

  3. Boxes will align themselves to the lowest-numbered box in the selection (the one drawn least recently).  

  4. To align to a particular box, select that box and choose Send to Back before aligning.

 

Note:  for framed boxes, the inner data boxes will be aligned, not the frames.

To distribute boxes:

  1. Select three more more boxes.

  2. Choose a Distribute command from the Edit menu.

  3. Boxes will evenly space themselves between the two outermost boxes.

 

 


Opening Dialog

ChemFinder 7 starts up with a new look.  By default, upon starting the program you are presented with a new Open dialog:

 

 

 

This dialog allows you to:

 

If you prefer, you can prevent this dialog from appearing at program startup.  To control this, use the new checkbox Show opening dialog on the General tab of the Preferences dialog (see picture below).

 

11/15:  This dialog now also comes up when you choose New... from the File menu (formerly just "New").  It does NOT come up when you click the File New toolbar button --- this still simply creates a blank form.


Open Last Form on Startup

2/12/01: a new checkbox on the Preferences General tab, Open last form on startup, allows you to indicate that at program startup you want to automatically open the last form you were using.

 

 

 

 


Revamped Search Options Dialog

Revised 4/26/01: changes in stereo dialog, marked in red below

2/16/01: the mechanism for specifying search options has been expanded and made friendlier.  To use the new scheme:

  1. Choose Preferences... from (a) the Search menu, (b) the File menu, or (c) the context menu when right-clicking a form or form box.  Note that there are now two tabs of the Preferences dialog devoted to searching:  Search Type and Search Details.

     

 

  1. On the Search Type tab, choose from one of five search types:  substructure, full structure, identity (also known as "registry lookup mode"), similar full, or similar substructure.  Four of these choices can be selected as always by toggling the two checkmarked items on the Search menu: 

 

  1. On the Search Type tab, indicate whether to search over current list or not.  This is a toggle which can also be operated from the Search menu.

     

  2. If one of the similarity search types is chosen, set the degree of similarity using the slider control, where 100% similarity is the same normal sub- or full-structure search, and 0% similarity hits everything in the database.

 

 

  1. On the Search Details tab, set various choices via checkboxes as always.

     

  2. To search stereochemistry, check the Match stereochemistry box.  If this box is not checked, any stereochemistry in the query will be disregarded during the search.  If it is checked:

Revised 4/26/01: the Match stereochemistry checkbox is disabled if Identity is selected on the Search Type tab.

  1. Click How... to specify the details of how stereochemistry is to be matched.  This brings up the new Stereochemical Search Preferences dialog:

Revised 4/26/01: Based on a suggestion from Jonathan, we revised the images in this dialog to suggest asymmetry, using little colored dots.  Based on a suggestion from Harold, we eliminated the squiggly bond.  Here is the new screen shot:

  1. For a tetrahedral stereo center (having wedge or hash), choose one of:

  1. For a stereo-capable double bond, choose one of:

 

Revised 4/26/01: The code is now modified to work as described above.  Note that choosing ANY is the same as saying "disregard stereo when matching at this center."  If you choose ANY for both tetrahedral and double bond sections of this dialog, then the "Match stereochemistry" box of the parent becomes unchecked.


Changes in Picture Boxes

 

3/26/01: Some changes were made in preparation for the demo at CS last week.  For a description of the problems being tackled, see problems with picture boxes.

 

This now works in a sort of hidden way.  There are two properties on the Preferences dialog dealing with pictures:  background color (Colors tab) and whether pictures are to be framed (Display tab).  These now specify the settings for new picture boxes; they do not change the status of existing boxes.  That is, when you create a new picture box, it takes from the current settings its background color and whether or not it is framed; afterwards changing the preference does not affect the box.  The only way to change these settings for an existing picture box is to delete and re-create it.

 

As before, if a picture is framed, it is drawn in a framed rectangular region filled with the chosen picture background color.  However, this is new:  if a picture is not framed, it is drawn with a transparent background and the background color is disregarded.  

 

The combination of these two features makes it possible to have both styles of picture on the same form, and to have the picture settings saved with the form.  Example: