5.1     UI Features


5 May 99

This page describes new features in the ChemFinder 5.1 User Interface. 

Note:  Some features present new tools on the toolbars.  If you do not see these tools, choose View Toolbars, Customize, check the toolbar in question, then click Reset.


Switch Views   wpe6.jpg (2568 bytes)

Developed initially for use by external clients, this feature turns out to be a handy way to save mouse clicks and screen space. 

Switch Views (View menu) changes the foremost window from form view to table view, or vice-versa.  The size and position of the window are retained.  This allows you to have table view on display without the corresponding form view, and makes it more convenient to manage views when there are several windows on display.

Switch Views is dimmed under the same conditions as View Data Table: you must have a form with one or more boxes, and an open database.  Within a subform, Switch Views works exactly the same way as View Data Table.  This command is not available in query mode.

To use:

  1. Bring up a form or table view of some data.
  2. Choose Switch Views.  The frontmost window will change to the alternate view.

Testing suggestions:  bring up a form or table, choose Switch Views a few times.  Try within subforms.  Try with resized, minimized windows.   Try executing from CAL.  Try saving form in switched view, check behavior on restore.

Status:  ready to test in 5.1d7


Omit Record  wpe8.jpg (2686 bytes)

In ChemFinder 5.1, by popular demand, you can edit the list you're browsing.  Omit Record (Record menu) takes the current record off the hitlist, eliminating it from any subsequent list operation --- export, search over, print, etc.  You can remove the single record you're viewing in a form, or a multi-record selection in table view.

The effect of Omit Record is exactly the same as if you (a) save the current hitlist, (b) edit the list file to remove the current record(s), then (c) restore the list file, using the Replace option.  [ In fact this is roughly the way the option works right now, but we'll implement something faster if time permits. ]

Omit Record does not delete any data from the database.   Each omission creates a new list; you can return to the previous list using Search Restore Previous List, or to the entire database by using Search Retrieve All.  Once you have removed records from a list, all subsequent list operations work over the reduced list as expected.

To use:

  1. Bring up a form.  You are viewing a record of a list (which may be the entire database).
  2. Choose Remove Record.  The record will be removed, and the view will change to the subsequent record.

or:

  1. Bring up a table view.
  2. Select one or more records by clicking (or shift- or ctrl-clicking) on the left edge of the records.
  3. Choose Remove Record.  All selected records will be removed, and the selection emptied.

Testing suggestions:  Try the recipes, ensure subsequent list operations work as expected.  Try removing all records from a list.  Try restoring previous lists, alternating between restores and removals, interspersing searches over current list.  Exercise in both form and table views.

Status:  ready to test in 5.1d7


Linear Reaction Layout

We've added a relatively hidden feature to alleviate some problems being encountered by Web Server.  By default, when the user takes a reaction on the screen in ChemFinder and goes to edit it in ChemDraw, the reaction is reorganized to fit within the ChemDraw work area --- currently hard-coded as a 400 X 400 rectangle --- which causes the typical reaction to end up on more than one line.  In Web Server, this leads to a big area of unused space, which looks grey and crummy.  It was requested that we make it possible to ensure that reactions come out on a single line within ChemDraw.

This is done by a new setting in cfw.ini:

[OPTIONS]

LINEAR_RXN_LAYOUT=1

Setting this value to 0 works as before.  Setting the value to 1 prevents reactions from occupying more than one line when transferred to ChemDraw.

For Automation clients, this new setting is available via the ExecuteCALCommand method.

Status:  ready to test in 5.1d7


Edit Script

Edit Script is a new item on the right-click context menu for a Button object on a form.  Choosing this option calls up Notepad.   If the button has a label, and there is a corresponding script file in the ChemFinder system directory, Notepad opens that file.  If the button has a label, but the file does not exist, Notepad handily asks if you want to create a new file by that name. 

If the button has no label, Notepad opens a blank window.   (Note that as of 5.1d7, it is possible to edit a button's label and erase it; previously this didn't work.)

Status:  ready to test in 5.1d7


Context Menu Changes

We discovered inconsistencies in the items on right-click context menus for various form objects.  Our policy about these menus is as follows:

Layout Mode                                                         Browse Mode

image51.gif (2101 bytes)                                                    image54.gif (1988 bytes)

Testing suggestions:  take a look at the context menus which come up on different box types, with or without a database connected, test functions on the menus, see if they appear consistent and intuitive.

Status:  ready to test in 5.1d7