BioViz Demo and Tutorial

28 Jun 2004


This is an outline of the material to be presented at the Webinar on June 30.  With a little added verbiage, it also serves as a tutorial for using BioViz in ChemFinder 9.0.  Follow along and you'll become a BioViz Whiz.


The Database

1.  Download zip file containing database, forms, and scripts: click BioViz Tutorial Database.  Unzip contents into a new folder.

2.  Open the form (pscreen.cfw) and it looks like this:

The database was created by importing a comma-delimited file of test data into a new database, then attaching an arbitrary set of structures taken from the ChemINDEX database.  Two physical properties were added, generated by the ChemFinder 9 Property Populator.  The data of interest are displayed on the front tab of the form; the complete set of text data is on the Raw Data tab.


Plotting

3.  Right-click the box "Fold_Above_Control" and choose BioViz Plot > 1D Plot.  The result shows the spread of activity values over the complete set of compounds:

4.  For a different view of the data, right-click the plot and choose Properties.  Select Histogram style, and choose Fold_Above_Control for the X variable:

5.  Click OK to see the histogram:

This shows the distribution of activity values over the database.  The largest block is at x = 1, representing "1-fold above the control value," which is to say, no activity compared to the control.  Let's restrict our attention to compounds with measurable activity, say > 1.5-fold.


Searching

6.  Return to the original plot: bring up Properties, choose Scatter Plot style, click OK.

7.  Click to bring the form window to the front.  Choose Search > Enter Query and type "> 1.5" in the Fold_Above_Control box.  Press Enter to perform the search.  You should get 147 hits.

8.  The plot updates to show the hitlist.  By default, the hits are shown on the same scale as the original list, which causes them to appear in a bunch at the left of the window.  Right-click the plot and choose Auto-scale.  This performs a rescale (as if you had chosen Rescale to All Points), and sets a switch so that all subsequent searches and list operations will automatically rescale the plot.

9.  Choose Window > Tile Horizontally to arrange the form and plot so both are visible.  (If there are other windows on the screen, close them and repeat the tiling operation.)

10.  Note the interaction between form and plot.  Click a point on the plot, and the form goes to that record.  Browse through the records in the form (use Record Next, Previous, etc.) and note that the corresponding point is highlighted in red on the plot.  

Notice that the point of highest activity has no structure associated with it.  Let's refine the list to exclude records without structures.

11.  Bring the form window to the front.  Use Search > Restore Previous Query to recall the activity query.  In the Molweight box, type "> 0" and press Enter to carry out the search.  You should now have 117 hits.

12.  For a cleaner view of the data, right-click in the Fold_Above_Control box and choose Sort > Ascending.  The plot now looks like this (although yours may be a different color):

13.  There is no step 13. 


Explorer Window: Database Tree

14.  If it's not already visible, choose View > Explorer Window.  Click the leftmost tab and take a look at the Database tree.

The Database tree shows the table connected to the current form, with all its columns -- the same data you see in the Database page of the Properties dialog.  In the Explorer Window, the Database tree is not used to manage the database (delete or add fields, etc.) but to create boxes on a form.  To see this in action:

15.  Right-click the form, choose Add Tab to create a new tab.  Click the tab so it comes to the front.

16.  Double-click any field in the Database tab.  A new box is automatically generated on the form and connected to the chosen field.

17.  Repeat for other fields.  To create the diagram above, we chose (in this order): Plate_Barcode, Control_Average, Structure, Partition_Coefficient_Octanol/Water.


Favorites Tree

18.  Bring the Favorites tab to the front.  The Favorites tree shows a user-built collection of folders and files of all types. 

19.  Double-click any file to open or launch it.  Right-click to manage folders and files.  Drag files from Windows Explorer into the tree.  Explore, experiment, enjoy.


Queries Tree

20.  Bring the Queries tab to the front.  You should see items Q1 and Q2 for the two searches done above.

The Queries tree shows entries for each search or list operation, plus any saved from previous sessions.  Each item is automatically assigned a color (which you can change), and a short description of the list origin, which shows up in a tooltip if you hover over the item.

21.  Double-click the Q1 item in the tree.  This selects the results of the selected query as the current list, and the form and the plot update to display it.  The plot becomes the same color as the query icon.

22.  Single-click the Q2 item.  This overlays the hits of Q2 onto the current list, showing the intersection of the two lists.

23.  Right-click either icon and choose Change Color.  You can choose a different color for any list.  (Note regarding small bug: when you change the color in the tree, the plot does not update immediately -- you have to unselect and reselect the list to update the plot.)


Structure Window

24.  If it's not already visible, choose View > Structure Window.  Resize or reposition the window as desired.

The Structure window shows the current structure, either that of the current record or that where the cursor is located on the plot.

25.  Brush the mouse across the plot.  The Structure window updates to show the structure under the cursor.


Filtering

26.  Right-click the plot window and choose Properties.  Create a new plot as follows:

This shows a 2-variable plot, with a filter on a third variable.

27.  Press the thumb at the left of the Molar_Refractivity slider and drag to the right.  As you drag, the plot filters out points excluded by the slider.  For example, in the diagram above, points having Molar_Refractivity less than 4 are removed from the plot.


Selection and Zooming

28.  Press anywhere on the plot and drag the corner of a selection rectangle.  Drag so it encloses some points, then release.  The points become selected and highlighted in red.  Note that the selection may be extended by ctrl-click or ctrl-drag.

29.  Right-click the plot and choose Selection To List.  This creates a new query (list) containing only the selected points.  The list shows up in the Queries tree, and becomes the current list.

30.  To go back to the previous list: double-click its icon in the Queries tree.

31.  Right-click the plot and choose Zoom On Drag, so it becomes checkmarked.

32.  Drag another selection rectangle around a portion of the plot.  When you release the drag, the view zooms to fill the screen with the selected area.

33.  Right-click and choose Unzoom to restore to the standard view.